Close
excel_logo

3.2. Mantiqiy Funksiyalar

Excelning shart (IF, ЕСЛИ),  “va” (AND, И) hamda “yoki” (OR, ИЛИ) kabi mantiqiy funksiyalarini qanday ishlatishni o’rganing.

Shart (If, Если) funksiyasi

ЕСЛИ (IF) funksiyasi biror shart bajarilishini tekshiradi, va agar rost (TRUE, ИСТИНА) bo’lsa bir qiymatni va agar yolg’on (FALSE, ЛОЖЬ) bo’lsa boshqa bir qiymatni qaytaradi.

C1 katakni tanlang, va quyidagi funksiyani kiriting.

=IF(A1>10,”To’g’ri”,”Noto’g’ri”) yoki

=если(A1>10,”To’g’ri”,”Noto’g’ri”)

shart1

ЕСЛИ (IF) funksiyasi “To’g’ri” qaytaradi chunki A1 katakdagi qiymat 10 dan kattaroq.

“VA” (And, И ) Funksiyasi

И (AND) funksiyasi agar barcha shartlar rost bo’lsa, rost (TRUE, ИСТИНА) qiymat qaytaradi, va agar shartlardan ihtiyoriy bittasi yolg’on bo’lsa, yolg’on (FALSE, ЛОЖЬ) qaytaradi.

D1 katakni tanlang va quyidagi formulani kiriting.

=IF(AND(A1>10,B1>5),”To’g’ri”,”Noto’g’ri”) yoki

=ЕСЛИ(И(A1>10,B1>5),”To’g’ri”,”Noto’g’ri”)

shart2

И (AND) funksiyasi yolg’on (FALSE, ЛОЖЬ) qaytaradi chunki B1 katakdagi qiymat 5 dan kata emas. Natijada ЕСЛИ (IF) funksiyasi “Noto’g’ri” qaytaradi.

“Yoki” (Or, Или) Funksiyasi

ИЛИ (OR) funksiyasi agar shartlardan ihtiyoriy bittasi rost (TRUE, ИСТИНА) bo’lsa, rost (TRUE, ИСТИНА) qaytaradi va barcha shartlar yolg’on bo’lsa, yolg’on (FALSE, ЛОЖЬ) qaytaradi.

E1 katakni tanlang va quyidagi formulani kiriting.

=IF(OR(A1>10,B1>5),”To’g’ri”,”Noto’g’ri”) yoki

= ЕСЛИ(ИЛИ(A1>10,B1>5),”To’g’ri”,”Noto’g’ri”)

shart3

ИЛИ (OR) funksiyasi rost (TRUE, ИСТИНА) qaytaradi, chunki A1 katakdagi qiymat 10 dan kattaroq. Natijada ЕСЛИ (IF)  funksiyasi “To’g’ri” qaytaradi.

Umumiy izoh: И (AND) va ИЛИ (OR) funksiyalari 255 tagacha shartlarni tekshira oladi.

(661 marta o'qilgan, bugun 2 marta o'qildi)

O'xshash maqolalar:

Leave a Reply

Your email address will not be published. Required fields are marked *