Close
excel_logo

3.2.1. Ichma-ich shartlar

Excelda bir nechta shartlarni tekshirishga to’g’ri kelib qolsa, ЕСЛИ (IF) funksiyasi ichma-ich bo’lishi mumkin. Testni davom ettirish uchun, yolg’on (FALSE, ЛОЖЬ) qiymat boshqa bir ЕСЛИ (IF) funksiya bilan almashtiriladi.

Izoh: agar sizda Excel 2016 bo’lsa, osongina (УСЛОВИЯ) IFS funksiyasidan foydalaning.

1a. Agar A1 katak 1 ga teng bo’lsa, formula “Yomon” degan qiymat qaytaradi.

= IF(A1=1,”Yomon”, IF(A1=2,”Yaxshi”, IF (A1=3,”A’lo”,” Yaroqli Ball Yo’q”))) yoki

=ЕСЛИ(A1=1,”Yomon”,ЕСЛИ(A1=2,”Yaxshi”,ЕСЛИ(A1=3,”A’lo”,” Yaroqli Ball Yo’q”)))

n-shart1

1b. Agar A1 katakni qiymati 2 ga teng bo’lsa, formula “Yaxshi” degan qiymat qaytaradi.

n-shart2

1c. Agar A1 katakni qiymati 3 ga teng bo’lsa, formula “A’lo” degan qiymat qaytaradi.

n-shart3

1d. Agar A1 katak boshqa qiymatga teng bo’lsa, formula “Yaroqli Ball Yo’q”.

n-shart4

Bu yerda yana boshqa bir misol.

2a. Agar A1 katak 10 dan kichik yoki teng bo’lsa, formula 350 qaytaradi.

=IF(A1<=10,350,IF(A1<=20,700,IF(A1<=30,1400,2000)))

= ЕСЛИ (A1<=10,350, ЕСЛИ (A1<=20,700, ЕСЛИ (A1<=30,1400,2000)))

n-shart5

2b. Agar A1 katak 10 dan katta va 20 dan kichik yoki teng bo’lsa, formula 700 qaytaradi.

n-shart6

n-shart7

2c. Agar A1 katak 20 dan kattaroq va 30 dan kichik yoki teng bo’lsa, formula 1400 qaytaradi.

n-shart8

2d. Agar A1 katak 30 dan kattaroq bo’lsa, formula 2000 qaytaradi.

n-shart9

Izoh: O’zingizning formulangizda chegaralarni biroz o’zgartirish uchun siz “<=” ning o’rniga “<” belgisini ishlatishingiz mumkin.

 

(638 marta o'qilgan, bugun 1 marta o'qildi)

O'xshash maqolalar:

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: